Excel. Función BUSCARV

Esta función de la categoría búsqueda y referencia nos permite buscar un valor dado en un rango de celdas y nos devolverá el valor correspondiente en el rango indicado.

funcion-buscarv-001.jpg

Descargar este ejemplo

Por ejemplo, con este rango de búsqueda al buscar el código del producto podríamos obtener la descripción, el precio o la cantidad en stock.

La sintaxis de la función BUSCARV es la siguiente:

funcion buscarv 002

Valor_buscado: qué estamos buscando, en el ejemplo el código del producto

Matriz_buscar_en: dónde buscamos, la matriz, el rango en el que buscamos, en el ejemplo sería $A$1:$D$24, también podríamos utilizar el nombre del rango si lo hubiéramos creado.

Indicador_columnas: el número de la columna que buscamos, por ejemplo si buscamos la descripción: 2, si buscamos precio: 3, si buscamos stock: 4; ten en cuenta que la matriz debe incluir como primera columna el valor buscado

Ordenado: VERDADERO si buscamos la coincidencia más cercana o FALSO si buscamos el valor exacto, este parámetro puede quedar vacío.

Pues con todo esto ya podemos hacer ejemplo:

Vamos a poner en la primera columna el código del producto, con esto tenemos que obtener la descripción, precio y la cantidad en stock.

=BUSCARV($A2;PRODUCTOS!$A$1:$D$32;2)

$A2: dónde hemos escrito el código, he fijado la columna con $ para poder copiar la fórmula en las dos columnas siguientes.

PRODUCTOS!$A$1:$D$32: ya que no he puesto nombre al rango lo bloqueo con $

2: el número de columna que corresponde a la descripción, en las siguientes columnas este valor en la función sería 3 para el precio y 4 para stock.

Probemos con otro ejemplo:

DESCARGA EL LISTADO

funcion buscarv 003

En este listado tenemos las localidades españolas (a fecha de 2012) y hemos creado un rango, LOCALIDADES, desde B2:F8117

Lo que pretendemos es crear una función que nos indique provincia y autonomía de la localidad que indiquemos, lo haremos en la hoja 2 por ejemplo algo así:

funcion buscarv 004

En la celda B2 figurará una función BUSCARV con los siguientes parámetros:

funcion buscarv 005

Valor_buscado: Dónde escribiremos el nombre de la localidad.

Matriz_buscar_en: He usado el nombre del rango que se ha creado, se podría poner también $B$2:$F$8117

Indicador_columnas: 3 para la provincia y 5 para la comunidad autónoma.

Ordenado: en esta ocasión es necesario marcar FALSO para que EXCEL busque la coincidencia exacta ya que habrá muchos errores y municipios escritos de distinta forma, si no lo marcamos daría muchos errores.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .

Blog de WordPress.com.

Subir ↑