Excel. Definir nombres de rango

Definir nombres de rango

Al definir el nombre de un rango de celdas en Excel, podemos utilizar este nombre en fórmulas y funciones, por ejemplo la función SUMA

=SUMA(A2:B35) que calcularía la suma del contenido de esas celdas, pero si definimos “Precios” como el rango desde A1 hasta B35 podríamos utilizarlo en cualquier función de este libro

=SUMA(“Precio”) mucho más cómodo y más intuitivo

Vamos a aplicarlo en este archivo para la función BUSCARV

Si vamos al administrador de nombres, en la ficha FÓRMULAS veremos los que ya están creados en este libro, por ahora ninguno.

Nombres de rango

Si pulsas sobre el botón “Nuevo…” podremos definir el nombre y las celdas que lo compondrán

002a

Ahora si queremos, por ejemplo, aplicar la función BUSCARV para localizar al agente que atendió la llamada 78 podremos hacerlo:

=BUSCARV(valor_buscado; matriz_buscar_en; indicador_columnas; [ordenadoP])

=BUSCARV(78;A2:I47;4;FALSO) – Sin nombre de rango

=BUSCARV(78;”Llamadas”;4;FALSO) – Con nombre de rango

Puede resultar muy cómodo si tenemos que utilizar este rango en varias funciones.

Rangos dinámicos

En el ejemplo anterior tenemos un total de 247 líneas con contenido pero si éstas fueran muchas o bien se van a añadir o quitar datos no podríamos utilizar estos nombres de rango, a no ser que éstos detectaran cuántas celdas tienen contenido.

Para hacer esto utilizaremos la función DESREF, esta función nos permite definir un rango numéricamente:

Función DESREF

Quedaría así:

=DESREF(A2;0;0;3;4) lo que sería A2:D3

Que quiere decir: desde la celda A2, 3 filas y 4 columnas.

Rango con DESREF

También podría ser: =DESREF(A2;2;2;3;4) desde la celda A2 dos celdas a la derecha y dos celdas hacia abajo, tres filas y 4 columnas, no tenemos que empezar en A2 sino que solo la utilizamos como referencia.

Rango con DESREF

Esta función se podría utilizar en la definición de nombres de rango.

Ahora usaremos la función CONTARA que cuanta cuántas celdas tienen contenido en el rango especificado; su uso más normalito sería =CONTARA(A1:D5) devolviendo como resultado el número de celdas que tienen contenido.

Pero esto es poco para nosotros: vamos a ver cuántas celdas tienen contenido en la columna A

=CONTARA(A:A)

Conforme vayamos escribiendo o borrando en esta columna se modifica el resultado de esta función.

Si queremos saber cuántas celdas tienen contenido en la fila 1 sería algo parecido a

=CONTARA(1:1)

Y podemos utilizar estas funciones dentro de la función que vimos antes DESREF

=DESREF(A1;0;0; CONTARA(A:A); CONTARA(1:1))

Esta función crea un rango con todas las celdas que tengan contenido en la hoja que estemos trabajando:

Nombre de rango con DESREF

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .

Crea un blog o un sitio web gratuitos con WordPress.com.

Subir ↑